Jump to content

USB 3.0 cable stuck in header

Recommended Posts


My USB 3.0 cable is completely stuck in my usb 3.0 header. I have only one on my motherboard (z170 pro gaming)

So I am unsure what to do. The plastic surroundings looks like it will come off when I pull too hard. So I tried pushing it down with the flat end of a screwdriver, but I still needed a lot of force for it.

I also tried prying with a screwdriver in the gaps, and now the header is feeling kinda loose. Any tips, and does anyone know a borderline of how much force I may use.
I wanted to remove it from the header for new CPU cooling unit, and cable management.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...